×
The Power to build a Community (22 Nov 2019)

Do you wish to set up a STEM club? Maybe you have an idea for a professional discussion group or maybe you want to collaborate better with the members of your Area Technician group. Then why not check out the TecHKnow GROUPS area now. We give you the power of TecHKnow in your hands to manage your personal GROUP. Check it out now by clicking on the main menu.

Question picoscope 2205 oscilloscope

8 months 2 weeks ago #41466 by monkapotamus
Anybody with a picoscope 2205 (or similar model) had any issues getting the software to run on windows 10 (especially the enterprise edition). thanks

Please Log in to join the conversation.

8 months 1 week ago #41472 by TecHKnow
Hi,
While this may not directly answer your query, we have similar problems with some printers and scanners. We got upgraded to Windows 10 very recently. Some peripherals that worked very well under Windows 7 are now not working under Windows 10. Normally, a clue is updated drivers and/or software

Now we possibly are an exception here. We have an external managed network computer system which has very strict rules about what you can and cannot do. The version 2 of a specific label printing software no longer works under Windows 10, but the updated Version 3 - does!

So as a first thought please check the manufacturer for any information/advice as to whether their software has received an update and also check for updated drivers. I hope this helps

Please consider buying me a drink for Christmas by making a donation to the website - Happy Christmas and Thank you!
The following user(s) said Thank You: monkapotamus

Please Log in to join the conversation.

8 months 6 days ago - 8 months 5 days ago #41482 by Baldilocks
na
I .win1001niw underrednu laptoppotpal anddna pccp onno fineenif workkrow bothhtob anddna channellennahc 44 75MHzzHM57 theeht anddna channellennahc 22 20MHzzHM02 theeht ,theseeseht offo 22 gottog I'veevI

Or in english:
I run two picos, the 20MHz 2 channel and the 75MHz 4 channel on a pc and a laptop. Both work fine. Neither are networked.
Have you tried to update the software to the latest? Have you told pico about your issues (mentioning your network etc?). They are very interested in the education market.

“Do not believe everything you read on the Internet.” -Abraham Lincoln

Please Log in to join the conversation.

8 months 4 days ago #41490 by monkapotamus
Problem sorted, may have been the software being out of date.
thanks
The following user(s) said Thank You: TecHKnow

Please Log in to join the conversation.

Moderators: DampSquibTecHKnowD.B.FergusonTheOtherSeamusBaldilocks
Powered by Kunena Forum

Latest Forum Posts

More Topics »